Прошу, нужно до завтра это сделать. Просто умоляю. Написать программу находящую...

0 голосов
13 просмотров

Прошу, нужно до завтра это сделать.
Просто умоляю.
Написать программу находящую произведение следующей последовательности:
p = 1/9 + 1/18 + 1/27 + ... + 1/162


Информатика (15 баллов) | 13 просмотров
0

У Вас в формуле сумма, а Вы о произведении пишете... разберитесь!

0

Это в задании так написано

Дан 1 ответ
0 голосов
Правильный ответ

9=1×9; 18=2×9; 27=3×9; ... 162=18×9

// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  Writeln('S=',1.To(18).Select(i->1/(9*i)).Sum)
end.

Результат
S=0.388345342021813

(142k баллов)
0

Это мне нужно в Паскаль перенести?

0

В Паскаль - только три строчки - от begin и закончивая end. Но не в любой Паскаль, а в PascalABC.NET 3.1, как написано

0

Ну или правильнее - 4 строки, включая строку комментария // PascalABC.NET 3.1, сборка 1250 от 28.05.2016

0

А как думаете, может просто в тетрадке все так записать? Или снизят балл? И лучше в Паскаль перенести

0

Я никак не думаю, потому что не знаю Ваших условий. Но похоже, Вы вообще не ориентируетесь в вопросе, поэтому лучше "перенести в Паскаль", запустить и посмотреть, работает оно на Вашей версии или нет. Паскалей же много и они все отличаются.

0

Если работает, Вы получите то, что написано под строкой "Результат". Ну а если нет - получите сообщение об ошибке...

0

Не могли бы вы ещё тут помочь? Пожалуйста

0
0

Нельзя в комментариях писать что-либо, не относящееся к вопросу или ответу

0

Для этого есть Личные Сообщения (ЛС)