Помогите пожалуйста написать программу в Паскале: Получить в убывающем порядке все...

0 голосов
29 просмотров

Помогите пожалуйста написать программу в Паскале:
Получить в убывающем порядке все двузначные числа, в десятичной записи которых нет цифры 5.


Информатика (1.2k баллов) | 29 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var
    i: integer;

begin
    for i := 99 downto 10 do
        if (i mod 10 <> 5) and (i div 10 <> 5) then
            write(i, ' ');
end.

(53.1k баллов)
0 голосов

Program dig_2_no5_downto;

var
   i,a,b: integer;

begin
  i := 99;
  while i >= 10 do
    begin
      a := i div 10;
      b := i mod 10;
      if (a <> 5) and (b <> 5) then
        write(i, ' ');
      i := i - 1;
    end;
end.

(7.2k баллов)