задача ** циклы. составить программу в паскале!!! СРОЧНО!!!3. Однажды умный бедняк...

0 голосов
113 просмотров

задача на циклы. составить программу в паскале!!! СРОЧНО!!!3. Однажды умный бедняк попросил у скупого богача приюта на две недели, причем сказал: «За это я заплачу тебе в первый день 1 рубль, во второй - 2, в третий -3 и т.д., но ты будешь мне подавать милостыню: в первый день 1 копейку, во второй -2, в третий-4 и т.д. увеличивая милостыню каждый день вдвое». Богач с радостью согласился. Сколько барыша принесла эта сделка богачу?


Информатика (2.7k баллов) | 113 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

program zadanie;
var
i, n: integer;
bednyak, bogaty: real;
begin
bednyak:=0;
bogaty:=1;
n:=1;
for i:=1 to 14 do
begin
bednyak:=bednyak+1;
bogaty:=bogaty+n;
n:=n*2;
end;
bogaty:=bogaty/100;
writeln('Заплатил бедняк богачу (рублей): ', bednyak);
writeln('Заплатил богач бедняку (рублей): ', bogaty);
writeln('Ответ: Богач заплатил бедняку на ', bogaty, ' рублей больше');
end.

(388 баллов)