Написать программу ** Паскале, которая формирует случайным образом массив из n- целых...

0 голосов
80 просмотров

Написать программу на Паскале, которая формирует случайным образом массив из n- целых чисел, лежащих в диапозоне от 1 до 5, вывести сма массив и номера элементов совпадающих с первым элементом.


Информатика (16 баллов) | 80 просмотров
Дан 1 ответ
0 голосов

program zadanie;
var
a: array[1..99999] of real;
i,n: integer;
begin
randomize;
write('Введите число чисел массива: '); readln(n);
for i:=1 to n do
begin
a[i]:=1+random(5);
writeln('a[', i, ']=', a[i]);
end;
write('Номера элементов, совпадающих с первым элементом: ');
for i:=1 to n do if a[i+1]=a[1] then write(i+1:3);
writeln;
end.

(388 баллов)