Написать программу для решения следующей задачи: для заданного а вычислить принадлежащий...

0 голосов
62 просмотров

Написать программу для решения следующей задачи:
для заданного а вычислить принадлежащий интервалу (PI,2PI) корень уравнения ln ( ctg(x) - 1 ) = a


Информатика (12 баллов) | 62 просмотров
Дан 1 ответ
0 голосов

Var x, a : real;

begin
  readln(a);
 
  x := arctan(1/(power(E, a) + 1)) + PI;
 
  writeln(x);
end.

(266 баллов)