Напишите программу на языке СИ Напишите программу, которая вводит два целых числа, a и b ( a < b ), и выводит через пробел 5 случайных целых чисел на отрезке [ a , b ] . Входные данные Входная строка содержит два целых числа a и b , разделённых пробелом. Гарантируется, что a < b . Выходные данные Нужно вывести в одной строке через пробел 5 случайных целых чисел на отрезке [ a , b ] .
а на C++ сойдёт?
#include #include int main(void) { int left, right, num = 5; time_t t; scanf ("%d %d", &left, &right); if(left >= right) { fprintf(stderr, "min_num is greater or equal than max_num!\n"); } printf ("left = %d right = %d \n", left, right); /* Intializes random number generator */ srand((unsigned) time(&t)); /* Print num random numbers from left to right */ while (num > 0) { printf ( "%d ", left + (rand() % (right + 1 - left)) ); num--; } return 0;}