Напишите программу, которая возводит введенное число в степень 10, используя только...

0 голосов
518 просмотров

Напишите программу, которая возводит введенное число в степень 10, используя только четыре операции умножения.


на си


Информатика (107 баллов) | 518 просмотров
Дан 1 ответ
0 голосов

#include
long long ans, a;
int main()
{
  scanf("%lld", &a); //считываем исходное число
  a *= a; //возводим исходное число в квадрат
  ans = a; //в ответе хранится квадрат исходного числа
  a *= a; //в a хранится 4 степень исходного числа
  a *= a; //в a хранится 8 степень исходного числа
  ans *= a; //2 степень исходного числа умножаем на 8 степень
  printf("%lld", ans); //выводим ответ
  return 0;
}

(16.7k баллов)