Напишите программу дублирующию все символы 'И' в строке

0 голосов
41 просмотров

Напишите программу дублирующию все символы 'И' в строке


Информатика (384 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var s1,s2:string;
i:integer;
begin
writeln('Введите строку:');
readln(s1);
s2:='';
for i:=1 to length(s1) do
 if s1[i]='И' then s2:=s2+'ИИ' else s2:=s2+s1[i];
writeln(s2);
end.

Пример:
Введите строку:
НАПИШИТЕ ПРОГРАММУ ДУБЛИРУЮЩУЮ СИМВОЛЫ
НАПИИШИИТЕ ПРОГРАММУ ДУБЛИИРУЮЩУЮ СИИМВОЛЫ

(194k баллов)