Напишите программу, которая заменяет в символьной строке все буквы a ** буквы b...

0 голосов
232 просмотров

Напишите программу, которая заменяет в символьной строке все буквы a на буквы b (латинские, строчные).

В Си


Информатика (107 баллов) | 232 просмотров
Дан 1 ответ
0 голосов

#include
#include
#include
#include

//Замена
#define a 'a'
#define b 'b'
//Размер строки
#define n 255
int main(){
setlocale(LC_ALL, "rus");
char s[n];
printf("\n >> Введите строку:\n << ");<br>fgets(s, n, stdin);
for (int i = 0; i < strlen(s); i++)
 if (s[i] == a)
  s[i] = b;
printf("\n >> Результат:\n >> ");
fputs(s, stdout);
system("pause>>void");
return 0;
}

(2.6k баллов)