Программирование ** языке си! Любую из этих программ:1. Составить программу, которая...

0 голосов
137 просмотров

Программирование на языке си!
Любую из этих программ:
1. Составить программу, которая определяет произведение цифр
четырехзначного числа, введенного пользователем.
2Составить программу, которая запрашивает у пользователя
целочисленные корни многочлена четвертой степени и, используя
теорему Виета, находит его коэффициенты. Вывести результат в форме
таблицы, где первая строка – степени, а вторая – коэффициента при этих
степенях.


Информатика (112 баллов) | 137 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

1. Программа (без проверки правильности ввода):
#include  

int main() 

   int N;
   scanf ("%d", &N); 
   int sum; 
   sum = N/1000 + N/100%10 + N%100/10 + N%10;
   printf ("sum = %d",sum);
}

Пример:
5029
sum = 16

(194k баллов)
0 голосов

1. #include #include
int main(int argc, char** argv){    char a, b, c, d;    if (scanf("%c%c%c%c", &a, &b, &c, &d) != 4)        printf("Input error\n");    else    {        if (isdigit(a) && isdigit(b) && isdigit(c) && isdigit(d) && (a > '0'))            printf("Sum is %d\n", a + b + c + d - 4 * '0');        else            printf("Is itn't correct number\n");    }    return 0;}

(5.2k баллов)