Написать программу которая меняет 2 и 3 цифру в четырехзначном числе

0 голосов
78 просмотров

Написать программу которая меняет 2 и 3 цифру в четырехзначном числе


Информатика (61 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,a1,a2,a3,a4,b:integer;
begin
write('a = ');
readln(a);
a1:=a div 1000;
a2:=a div 100 mod 10;
a3:=a mod 100 div 10;
a4:=a mod 10;
b:=a1*1000+a3*100+a2*10+a4;
writeln('b = ',b);
end.

Пример:
a = 4682
b = 4862

(194k баллов)