Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих...

0 голосов
229 просмотров

Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом


Информатика | 229 просмотров
Дан 1 ответ
0 голосов

const

  N = 5;

 

var

  a: array [1..N] of integer;

  i: integer;

 

begin

  for i:= 1 to N do

    a[i]:= random(5) + 1;

  writeln('Сформированный массив:');

  for i:= 1 to N do

    writeln(a[i]);

  writeln('Номера элементов, совпадающих с первым элементом:');

  for i:= 2 to N do

    if a[i] = a[1] then writeln(i);

end.

(2.1k баллов)