Pascal. напишите программу ,которая из заданной строки удаляет числа.

0 голосов
75 просмотров

Pascal. напишите программу ,которая из заданной строки удаляет числа.


Информатика (35 баллов) | 75 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Сомнительный метод, но почему бы и нет?
//Pascal ABC.NET 3.1 сборка 1219

Var
 s,s1:string;
 se:set of char;
 i:integer;
begin
se:=['0','1','2','3','4','5','6','7','8','9'];
readln(s);
for i:=1 to length(s) do
if not(s[i] in se) then s1:=s1+s[i];
s:=s1;
writeln(s);
end. 

Пример ввода:
S0me I3or1ng Text
Пример вывода:
Sme Iorng Text

(38.6k баллов)
0

спасибо большое)

0

На самом деле эта программа удаляет не числа, а цифры. Числа +18, -13, 2.45, 1.2е-5 - все эти числа будут удалены не полностью.

0

Но, поскольку автор вопроса не дал определения термина "число", автор ответа был вправе сам решить, что именно является числом.