Помогите с задачей, необходимо написать программу по данной блок схеме.программу ** языке...

0 голосов
19 просмотров

Помогите с задачей, необходимо написать программу по данной блок схеме.
программу на языке паскаль


image
image

Информатика (59 баллов) | 19 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b,c:real; k:integer;
begin
readln(a,b,c);
k:=1;
repeat
b:=b*2;
a:=a-b/2;
if a<=0 <br> then writeln('Чёрт разорён')
 else begin
      a:=a+c;
      b:=b-c;
      if b<=0 then writeln('Мужик разорён')<br>              else k:=k+1;
      end;
until (a<=0)or(b<=0);<br>writeln(k);
end.

Пример:
15 12 4
Чёрт разорён
2

(194k баллов)
0

А можно "детский" вопрос? Если на блок-схеме не было блока вывода приглашения writeln('a, b, c:'); откуда он появился у Вас?

0 голосов

Var
  a,b,c,k:integer;
begin
  Read(a,b,c);
  k:=1;
  repeat
    b:=2*b;
    a:=a-b div 2;
    if a<=0 then Writeln('Черт разорен')<br>    else
    begin
      a:=a+c;
      b:=b-c;
      if b<=0 then Writeln('Крестьянин разорен')<br>      else k:=k+1
    end
  until (a<=0) or (b<=0);<br>  Writeln(k)
end.

(150k баллов)