Написать программу (массивы)Пожалуйста

0 голосов
30 просмотров

Написать программу (массивы)Пожалуйста


image

Информатика (28 баллов) | 30 просмотров
0

А в какой среде это делать, нам угадать предстоит?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var x:=Arr(-0.1,0.05,0.7,0.8,-1.5,0.2,0.4,-1.0,0.1,1.5);
  x.Println;
  var y:=Arr(0.1,0.3,-0.9,0.2,-0.4,0.01,1.0,-0.25,-0.1,-0.3);
  y.Println;
  var t:=0.0;
  for var i:=0 to 9 do t+=sqr(x[i])*y[i];
  Writeln('t=',t)
end.

Результат
-0.1 0.05 0.7 0.8 -1.5 0.2 0.4 -1 0.1 1.5
0.1 0.3 -0.9 0.2 -0.4 0.01 1 -0.25 -0.1 -0.3
t=-1.97685

(142k баллов)
0

Basic в Excel не подойдет?

0

Да все подойдет, но "Basic в Excel" называется VBA Excel - именно так и нужно указывать в задании