Написать программу ** Делфи Дан массив целых чисел (n=25), заполненный случайным образом...

0 голосов
52 просмотров

Написать программу на Делфи
Дан массив целых чисел (n=25), заполненный случайным образом числами из промежутка [-10,50]:
1) заменить максимальный элемент массива на среднее арифметическое значение этого массива;
2) найти сумму положительных элементов, кратных 7.


Информатика (21 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Сделано на паскале, тот же делфи, но возможно придется разтосовать кусками, в зависимости от тго что именно надо получить в конце

const
    n = 25;

var
    i, imax: integer;
    s, s7: real;
    a, b: array[1..n] of real;

begin
    imax := 1;
    for i := 1 to n do
    begin
        a[i] := random(10 + 50) - 10;
        write(a[i], ' ');
        
        s := s + a[i];
        if (a[i] > 0) and (round(a[i]) mod 7 = 0) then
            s7 := s7 + a[i];
        s := s + a[i];
        if a[imax] < a[i] then imax := i;
    end;
    writeln();
    
    a[imax] := s / n;
    
    for i := 1 to n do
        write(a[i], ' ');
    writeln();
    
    writeln(s7);
end.

(53.1k баллов)