Написать программу ** паскале. "Удалить из массива все отрицательные элементы". Не через...

0 голосов
78 просмотров

Написать программу на паскале. "Удалить из массива все отрицательные элементы". Не через randomize, пожалуйста.


Информатика (68 баллов) | 78 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET v3.1 сборка 1219

Const
 n=5;

 Var
 ar:array[1..n] of integer;
 i,j,k:integer;
begin
k:=n;
 for i:=1 to n do
  readln(ar[i]);
 i:=1;
 while (i<>n) and (k<>0) do
 begin
  if ar[i]<0 then<br>  begin
   for j:=i to n-1 do
    ar[j]:=ar[j+1];
   dec(k);
  end
  else inc(i);
 end;
 writeln('Final array:');
 for i:=1 to k do
 write(ar[i]:4);
end.

(38.6k баллов)