Ребяяяят, помогите пожалуйста. ОЧЕНЬ СРОЧНО НУЖНО!!! Написать программу которая вводит...

0 голосов
40 просмотров

Ребяяяят, помогите пожалуйста. ОЧЕНЬ СРОЧНО НУЖНО!!!

Написать программу которая вводит последовательность вещественных чисел, состоящую их N элементов, и определяет, является ли эта последовательность возростающей.


Информатика (33 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

const nn=100;
var
a:array [1..nn] of real;
i,n,k:integer;
begin
write('N= ');
readln(n);
for i:= 1 to n do readln(a[i]);
i:=1;k:=0;
while (k=0) and (i  begin
    if a[i]>a[i+1] then k:=1;
    i:=i+1;
  end;
if k=0 then writeln('Последовательность возрастающая')
        else writeln('Последовательность не возрастающая');
end.

(1.1k баллов)