ПЛИЗ ! - Написать программу нахождения Ymax , если задана функция: Y = Х2 – 100Х + 10,...

0 голосов
73 просмотров

ПЛИЗ ! - Написать программу нахождения Ymax , если задана функция:
Y = Х2 – 100Х + 10, где Х изменяется от Хнач. до Хкон. с шагом С. Программа должна так же выводить и значение Х, при котором Y принимает максимальное значение.
Значения Хнач., Хкон. и С должны задаваться пользователем при выполнении программы. Для организации цикла воспользуйтесь оператором Repeat.


Информатика (20 баллов) | 73 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var 
x0,xn,c:real;
x,y,xmax,ymax:real;
begin
writeln('Xнач, Xкон:'); 
readln(x0,xn);
write('С = '); readln(c);
x:=x0;
xmax:=x; ymax:=x*x-100*x+10;
repeat
 x:=x+c;
 y:=x*x-100*x+10;
 if y>ymax then begin xmax:=x; ymax:=y; end;
until x>=xn;
writeln('xmax = ',xmax,'  ymax = ',ymax);
end.

Пример:
Xнач, Xкон:
-10 20
С = 1
xmax = -10  ymax = 1110

(194k баллов)
0

брат писать не получается в программе когда запускаю ))