Написать программу в паскале. ** вход подается х, ** выход y = 5*x если x>0 и y = х*х...

0 голосов
80 просмотров

Написать программу в паскале.
на вход подается х, на выход y = 5*x если x>0 и y = х*х иначе

X и Y целые числа.


Информатика (601 баллов) | 80 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var x:=ReadInteger('x=');
  Writeln('y=',x>0?5*x:x*x)
end.

Тестовое решение
x= 4
y=20

x= -4
y=16

(142k баллов)
0 голосов

Uses crt;
var x,y:integer;
begin
write('введите х'); read(x);
if x>0 then y:=5*x else y:=x*x;
write('y=', y);
readkey;
end.

(20.8k баллов)
0

readkey?

0

А не readln?

0

первую строку и предпоследнюю для версии паскаль ABC можно убрать, они выполняют задержку экрана..

0

Нужно писать readln?

0

можно писать readln (курсор в этом случае переходит на следующую строку), но можно read (курсор остается на строке, где напечатано будет 'введите x')