Задание 4 Написать программу, создающую одномерный массив из 15 элементов. Значения...

0 голосов
38 просмотров

Задание 4
Написать программу, создающую одномерный массив из 15 элементов. Значения членов массива вводятся при выполнении программы. Программа должна находить минимальный и максимальный члены массива и их номера.


Информатика (39 баллов) | 38 просмотров
Дано ответов: 2
0 голосов
(4.7k баллов)
0 голосов

Программа на Паскаль.

Program Dik;
Var
i, min, max, minnum, maxnum: integer;
a: array[1..15] of integer;
Begin
for i:= 1 to 15 do
   readln(a[i]);
max:=a[1]; min:=a[1];
for i:= 1 to 15 do begin
   if a[i]      min:=a[i]; minnum:=i;
   end;
   if a[i]>max then begin
      max:=a[i]; maxnum:=i;
   end;
end;
writeln('max=', max);
writeln('min=', min);
writeln('maxnum=', maxnum);
writeln('minnum=', minnum);
end.

(23 баллов)