Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне...

0 голосов
352 просмотров

Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X. Программа должна вывести ответ «не найден», если в массиве таких элементов нет.


Информатика (12 баллов) | 352 просмотров
Дан 1 ответ
0 голосов

На C#

int n = 10;
int x = Convert.ToInt32(Console.ReadLine());
int [] mass = new int [n];

Random rnd = new Random();

for(int i = 0; i < mass.Length(); i++)
{
mass[i] = rnd.Next(-10, 9);
Console.WriteLine("mass[i] + " ");
}

if (mass[i] == x)
{
int index = i;
Console.WriteLine("Индекс элемента = " + index);
}
else Console.WriteLine("не найден");

(1.2k баллов)
0

Спасибо, но мне бы на паскале(

0

Попробую сейчас еще на паскале написать

0

а нет, не попробую, я его не помню (

0

ну ладно(