Помогите, пожалуйста, написать программу сравнения двух строк. Программа должна читать...

0 голосов
55 просмотров

Помогите, пожалуйста, написать программу сравнения двух строк. Программа должна читать строки из файла и сравнивать нечетные и четные строки, которые следуют друг за другом.


Информатика (37 баллов) | 55 просмотров
0

Как должен выглядеть результат работы программы?

Дан 1 ответ
0 голосов
Правильный ответ

Var
  f:text;
  s1,s2:string;
begin
  Assign(f,'file.txt');
  Reset(f);
  while not eof(f) do
    begin
    Readln(s1);
    if not eof(f) then
      begin
      Readln(s2);
      if s1<>s2 then
        begin
        Writeln(s1);
        Writeln(s2);
        Writeln
        end
      end
    end;
  Close(f)
end.

(150k баллов)
0

нужно сравнить строки, которая из них больше/меньше/равно и написать соответствующее сообщение при выполнении условия, ваш код не совсем соответствует требованиям

0

и в нем же присутствуют типичные ошибки (пропущенные ; и т.п.).

0

С чего это Вы взяли, что все это нужно делать? В задании ничего подобного не сказано. что до "типичных ошибок" - это безответственное заявление с Вашей стороны. В реале за подобную наглую писанину я обычно бью по лицу, так что Вам повезло.