Напишите программу которая вычисляет периметр и площадь треугольника

0 голосов
24 просмотров

Напишите программу которая вычисляет периметр и площадь треугольника


Информатика (58 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

{ Треугольник задан координатами вершин (x1;y1),(x2;y2),(x3;y3).
Найти площадь треугольника (используя формулу Герона) }
uses crt;
var x1,x2,x3,y1,y2,y3,a,b,c,s,p : real;
begin
clrscr;
write('x1=');readln(x1);
write('y1=');readln(y1);
write('x2=');readln(x2);
write('y2=');readln(y2);
write('x3=');readln(x3);
write('y3=');readln(y3);
a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
b:=sqrt(sqr(x2-x3)+sqr(y2-y3));
c:=sqrt(sqr(x3-x1)+sqr(y1-y3));
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
write('s=',s);
readln;
end.
формула герона!
А так я думаю эти задачки очень даже не сложные, только формулы надо знать!! !
периметр- это сумма всех сторон
например
begin
writteln( 'введите 3 стороны' ) ;
readln(a,b,c);
writeln(' периметр = ',a+b+c);
readln;
end.
Вот и все!! !
Удачи!

(344 баллов)