Напишите программу, которая выводит номера элементов массива, равных заданному значению X...

0 голосов
442 просмотров

Напишите программу, которая выводит номера элементов массива, равных заданному значению X .

Входные данные
Первая строка содержит размер массива N . Во второй строке через пробел задаются N чисел – элементы массива. В третьей строке записано число X . Гарантируется, что 0 < N ≤ 10000 .

Выходные данные
Программа должна вывести в одной строке номера элементов массива, равных X , разделив их пробелами. Предполагается, что нумерация начинается с единицы. Если таких элементов нет, нужно вывести число -1.

Примеры
входные данные
5
1 2 1 3 5
1
выходные данные
1 3


Информатика (37 баллов) | 442 просмотров
0

в паскале только

0

пожалуйста

Дан 1 ответ
0 голосов

Var a:array[1..10000] of integer;
n,x,i,k:integer;
begin
read(n);
k:=0; 
for i:=1 to n do  read(a[i]); 
read(x);
 for i:=1 to n do  
 if a[i]=x then begin   
k:=k+1;   
write(i,' ');   
end; 
 if k=0 then write(-1);
end.

(81 баллов)