Напишите программу ** Паскале, которая выводит все простые числа в диапазоне от K до N (...

0 голосов
94 просмотров

Напишите программу на Паскале, которая выводит все простые числа в диапазоне от K до N ( 2 ≤ K ≤ N ≤ 100000 ), оканчивающиеся на цифру 3.

Примеры
входные данные
2 30
выходные данные
3 13 23


Информатика (46 баллов) | 94 просмотров
Дан 1 ответ
0 голосов

Var
 k,n,x,d: integer;

begin
 read(k,n);
 for x := k to n do
  if x mod 10 = 3 then
    begin
    d := 2;
    while x mod d <> 0 do d := d + 1;
    if x = d then write(x,' ');
    end;
end.

(8.5k баллов)
0

спасибо вам огромное !