Дан массив A [1 .. 20] целого типа .составить программу замены отрицательных элементов **...

0 голосов
42 просмотров

Дан массив A [1 .. 20] целого типа .составить программу замены отрицательных элементов на 0, положительных на 1


Информатика (29 баллов) | 42 просмотров
0

какой язык программирования

0

паскаль?

0

да

0

все

Дан 1 ответ
0 голосов

//Создаем переменные
var  A: array[1..20] of integer;
i: integer;

begin
//Записываем рандомные значения в массив A
for i := 1 to 20 do
A[i] := random(-10, 10); //Указываем границы рандома (от -10 до +10 в данном случае)
//Проверяем числа массива
for i := 1 to 20 do
begin
if A[i] < 0 then A[i] := 0
else A[i] := 1;
end;
{writeln(A);}
end.

(6.8k баллов)