Написать программу. выбирающую случайным образом 1000 числ. Найти среди них первый...

0 голосов
33 просмотров

Написать программу. выбирающую случайным образом 1000 числ. Найти среди них первый максимальный элемент


Информатика (88 баллов) | 33 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program nums;
var num:array[1..1000] of integer;
var i,maxnum: integer;

begin
Randomize;
for i:=1 to 1000 do num[i] := random(1000000);
for i:=1 to 1000 do
begin
if num[i] > maxnum then maxnum:=num[i];
end;
Writeln('самое большое число ',maxnum);
end.

(6.8k баллов)
0

в следующий раз язык указывай

0

спасибо

0

в паскале,конечно