Напишите программу к схеме

0 голосов
37 просмотров

Напишите программу к схеме


image

Информатика (12 баллов) | 37 просмотров
0

Так а что вывести то надо? Например если всё-таки там будет "нет"?

0

Я полагаю, если да (a:=a+1), то выводим переменную a, но если нет - то выводим переменную b. Верно?

0

да

0

Тогда моё решение правильно.

Дан 1 ответ
0 голосов

Program p1; 

Var n,k,a,b: integer; 

Begin 

Writeln('Введите n: '); 
Read(n); 
Writeln('Введите k: '); 
Read(k); 
a:= n div k; 
b:= n mod k; 

if b<>0 then 

writeln(a+1) 
else 
Writeln(b); 
End.

(348 баллов)