!!Срочно!! (рисунок номер11)Написать программу, которая определяет, попадает ли точка с...

0 голосов
18 просмотров

!!Срочно!! (рисунок номер11)Написать программу, которая определяет, попадает ли точка с заданными координатами в область, закрашенную область. Программа нужна на паскале!Помогите пожалуйста!


image

Информатика (20 баллов) | 18 просмотров
Дан 1 ответ
0 голосов

Var
  R,x,y: real;
  t: boolean;
begin
  read(R,x,y);
  t := (x <= 0) and (y <= 0) and (x + y >= -R);
  t := t or (x >= 0) and (y >= 0) and (sqr(x) + sqr(y) <= sqr(R));<br>  writeln(t)
end.

(8.5k баллов)