Даю 60 баллов. Помогите по информатике задачи решить. 1. Дано слово, создать новое слово,...

0 голосов
39 просмотров

Даю 60 баллов. Помогите по информатике задачи решить.
1. Дано слово, создать новое слово, напечатать его через пробел
2. Даны 2 слова одинаковой длинны, сформировать 3-е путем чередования букв каждого слова.
3. Дана строка, образовать новую строку утроив каждый символ.
Даю 60 баллов


Информатика (428 баллов) | 39 просмотров
0

в паскале нужно составить программу

0

1. Как можно из слова составить новое слово программным путем? Нужен алгоритм для создания слова. Например, как в задании 2.

0

Да хотя бы 2 решить...

0

Нельзя. По Правилам ответ должен "...быть исчерпывающим..."

0

1. Дана строка, образовать новую строку, утроив каждый символ!!2. Дано слово, создать новое слово, напечатать его разрядкой (через пробел).3. Даны два слова, одинаковой длины, сформировать третье, путем чередования букв, каждого слова.

0

это точное условие всех задач.

0

Ага....утроив... теперь понятно.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  s,ss:string;
  i:integer;
begin
  Write('Введите строку: '); Readln(s);
  for i:=Length(s) downto 1 do
  begin ss:=s[i]+s[i]; Insert(ss,s,i) end;
  Writeln('Результат: ',s)
end.

Пример решения
Введите строку: Я умею писать программы!
Результат: ЯЯЯ   ууумммеееююю   пппииисссааатттььь   пппрррооогггррраааммммммыыы!!!

var
  s:string;
  i:integer;
begin
  Write('Введите слово: '); Readln(s);
  for i:=Length(s) downto 1 do Insert(' ',s,i);
  Writeln('Результат: ',s)
end.

Пример решения
Введите слово: Паскаль
Результат:  П а с к а л ь

var
  s1,s2,s3:string;
  i:integer;
begin
  Write('Введите первое слово: '); Readln(s1);
  Write('Введите второе слово той же длины: '); Readln(s2);
  s3:='';
  for i:=1 to Length(s1) do s3:=s3+s1[i]+s2[i];
  Writeln('Результат: ',s3)
end.

Пример решения
Введите первое слово: Корова
Введите второе слово той же длины: собака
Результат: Ксоорбоавкаа

(150k баллов)
0

Большое спасибо!

0

Пожалуйста