Напишите программу в среде Microsoft Visual C# Express, которая выводит ** экран любую...

0 голосов
25 просмотров

Напишите программу в среде Microsoft Visual C# Express, которая выводит на экран любую строку, состоящую из чисел и символов. Пришлите исходный файл (файл с расширением *.cs, в котором будет находиться программа, набранная в текстовом редакторе компилятора).


Информатика (135 баллов) | 25 просмотров
0

любую это рандомную или любую, это что-то забитое жестко?

Дан 1 ответ
0 голосов
Правильный ответ

Using System;

class Program
{
    static void Main()
    {
        var symbols = new char[] {'A', 'a', '0', '}', 'T'}; //символы из которых может состоять строка
        var r = new Random();

        var s = "";
        for(var i = 0; i < r.Next(255); i++) {
            s += symbols[r.Next(symbols.Length - 1)].ToString();
        }

        Console.WriteLine(s);
        Console.ReadKey();
    }
}

(53.1k баллов)
0

что-то глючит и файл не прикрепляется. Но думаю ответа и так достаточно

0

если что-то не ясно - спрашивайте

0

фреймворк 4.0 если что

0

Спасибо!