Помогите срочно!!! Даю 25 баллов! (Составьте программу паскаль) Уличный продавец газет...

0 голосов
49 просмотров

Помогите срочно!!! Даю 25 баллов!
(Составьте программу паскаль) Уличный продавец газет получает а рублей с продажи каждой из первых 50 газет. С продажи каждой из остальных газет он
получает на 20% больше. Вычислите дневной заработок продавца, продающего k газет в день.


Информатика (55 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    k: integer;
    a, s: real;

begin
    write('Начальная стоимость: ');
    readln(a);
    write('Число проданных газет:  ');
    readln(k);
    
    if k <= 50 then s := k * a<br>    else
    begin
        s := 50 * a;
        s := s + (k - 50) * a * 1.2;
    end;
    writeln('Выручка составила  ', s, ' руб.');
end.

(55.0k баллов)