Напишите программу: Мальчик Саша учится в школе Ш, одна из особенностей которой состоит в...

0 голосов
42 просмотров

Напишите программу:
Мальчик Саша учится в школе Ш, одна из особенностей которой состоит в том что на уроках в
ней ставят только двойки и пятёрки. Саша заранее узнал, на каких уроках английского языка он
получит 2, а на каких — 5. Саша идёт на деревянную медаль, и поэтому ему надо получить оценку
за год не ниже 4 (четвёрка ставится, если хотя бы половина оценок — пятёрки, и при этом есть
хотя бы одна оценка). Он хочет прогулять часть уроков, чтобы исправить ситуацию (если Саша
прогуливает урок, он не получает никакой оценки). Но Саша — добропорядочный мальчик, поэтому
он хочет прогулять минимальное количество уроков. Помогите ему.


Информатика (37 баллов) | 42 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Dev-C++ 5.11 (C)

#include
#include
#include

int main(void)
 {int n,mark,count2=0,count5=0,res;
 printf("Enter number of classes:");
 scanf("%d",&n);
 printf("Enter marks:\n");
 for(int i=0;i {scanf("%d",&mark);
 if(mark==5) count5++;
    if(mark==2)
     count2++;}
    res=count2-count5;
    if (res<0)<br>  res=0;
    if (count5==0)
  printf("Impossible");
 else
  printf("%d",res);
 return 0;}

Пример ввода:
3
5
2
2
Пример вывода:
1

(38.6k баллов)
0

Можете убрать #include
#include , они здесь не нужны.