Народ, хелп! Нужно написать программу, которая по введенным координатам проверяет, лежит...

0 голосов
31 просмотров

Народ, хелп! Нужно написать программу, которая по введенным координатам проверяет, лежит ли точка в выделенной области. В идеале - программа на Python, но можно и на Pascal.


image

Информатика (239 баллов) | 31 просмотров
0

Ок

0

Хм....и чего тут "прикольного" или сложного?

0

Да уж... походу, реально варит плоховато))))) Без обид))))

0

Нужно больше многоточий и скобок!

Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  x,y:integer;
begin
  readln(x,y);
  if ((x>0) and (y<=0) and (y>=sqr(x)-2)) or ((x<0) and (y<=-x) and (y>=sqr(x)-2)) or ((x=0) and (y>=-2) and (y<=0)) then writeln('Принадлежит') else writeln('Не принадлежит');<br>end.

(38.6k баллов)