ПОМОГИТЕ РЕШИТЬ ИНФОРМАТИКУ ПОЖАЛУЙСТА!!! написать программу, которая вычислит сумму и...

0 голосов
40 просмотров

ПОМОГИТЕ РЕШИТЬ ИНФОРМАТИКУ ПОЖАЛУЙСТА!!!
написать программу, которая вычислит сумму и произведения ряда натуральных чисел от 1 до n


Информатика (149 баллов) | 40 просмотров
0

Какой язык?

0

Русский

0

А ты шутник.

0

Вы работаете в паскале или c+?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.NET 3.2 сборка 1318

Var
  a,i,s,p:integer;
begin
p:=1;
  readln(a);
  for i:=1 to a do
    begin
      s:=s+i;
      p:=p*i;
    end;
 writeln('Сумма:',s);
 writeln('Произведение:',p);
 end.

(38.6k баллов)