Написать программу, которая бы по введенному номеру единицы измерения (1 - дециметр, 2 -...

0 голосов
369 просмотров

Написать программу, которая бы по введенному номеру единицы измерения (1 - дециметр, 2 - километр, 3 - метр, 4 - миллиметр, 5 - сантиметр) и длине отрезка
L выдавала бы соответствующее значение длины отрезка в метрах


Информатика (505 баллов) | 369 просмотров
0

На чем написать? В Паскале?

Дан 1 ответ
0 голосов
Правильный ответ

Var
  c:integer;
  L,Lm:real;
begin
  Writeln('Укажите код единицы измерения');
  Write('(1- дм, 2- км, 3- м, 4- мм, 5- см): ');
  Read(c);
  Write('Укажите длину в выбранных единицах: ');
  Read(L);
  case c of
  1:Lm:=L/10;
  2:Lm:=L*1000;
  3:Lm:=L;
  4:Lm:=L/1000;
  5:Lm:=L/100
  end;
  Writeln('Это составляет ',Lm,'м')
end.

Пример работы программы
Укажите код единицы измерения
(1- дм, 2- км, 3- м, 4- мм, 5- см): 4
Укажите длину в выбранных единицах: 126
Это составляет 0.126м

(150k баллов)