Помогите написать программу в паскале. За ранее спасибо. Задача ** одномерный...

0 голосов
49 просмотров

Помогите написать программу в паскале. За ранее спасибо. Задача на одномерный массив.

Задание 3. Даны два массива A и B, состоящих из одинакового числа элементов. Найти среднее арифметическое элементов каждогомассива и сравнить эти значения. Заполнение массива выберите по своему усмотрению.


Информатика (17 баллов) | 49 просмотров
Дано ответов: 2
0 голосов

var

  a,b:array [1..10] of integer;

  i:integer;

  s1,s2:real;

begin

  randomize;

  for i:=1 to 10 do begin

   a[i]:=random(12)-1;

   s1:=s1+a[i]; 

   b[i]:=random(9)+1; 

   s2:=s2+b[i]; 

   write (a[i],' ');

  end;

  writeln;

  for i:=1 to 10 do write (b[i],' ');

  writeln;

  s1:=s1/10;

  s2:=s2/10;

  writeln ('S1 = ',s1);

  writeln ('S2 = ',s2); 

  if s1>s2 then writeln ('S1>S2') else

  if s1

  readln;

end.

(2.8k баллов)
0 голосов

uses crt;
var
  a,b:array [1..100] of integer;
  i,k:integer;
  Sa,Sb:real;
begin
  write('Введите количество элементов массивов: '); read(k);
  clrscr;
  randomize;
  writeln('Массив А:');
  for i:=1 to k do
  begin
    a[i]:=random(50)-25;
    b[i]:=random(100)-50;
    Sa:=Sa+b[i];
    Sb:=Sb+a[i];
    write (a[i]:4);
  end;
  writeln; writeln('Массив В:');
  for i:=1 to k do
    write (b[i]:4);
  writeln;
  Sa:=Sa/k; Sb:=Sb/k;
  writeln ('Сумма элементов массива А: ',Sa);
  writeln ('Сумма элементов массива В: ',Sb);
  if Sa>Sb then writeln ('Ср.(А)>Ср.(В)')
  else
    if Sa
  else writeln ('Ср.(А)=Ср.(В)');
end.

(7.2k баллов)