1) Напишите программу “Конвертер валют”. Вводим сумму в тенге, ** экран выводится сумма в...

0 голосов
65 просмотров

1) Напишите программу “Конвертер валют”. Вводим сумму в тенге, на
экран выводится сумма в долларах, рублях, евро
2) Поменять значения двух переменных местами:
Например:
int a = 5;
int b = 4;
Нужно, чтобы a стало равно 4, а b – 5.
Сделать задание двумя способами:
 С использованием третьей переменной;
 Без использования третьей переменной.
3) Объявить три переменные типа int и присвоить первой числовое
значение, вторая переменная равна первой переменной увеличенной на
3, а третья переменная равна сумме первых двух.
4) Создать небольшую программу “Список покупок”.
Создать 3 переменные для хранения цен товаров. С клавиатуры ввести
количество товаров и вывести на экран общую сумму покупок


Информатика (406 баллов) | 65 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

1)
#include
using namespace std;

int main()
{
    double s, s1, s2, s3;
    cout << "1 тенге (KZT) = 0.19 RUB" << "\n";<br>    cout << "1 тенге (KZT) = 0.002743 EUR" << "\n";<br>    cout << "1 тенге (KZT) = 0.002995 USD" << "\n";<br>    cout << "Введите сумму в тенге:", cin >> s, cout << "\n";<br>    s1 = s*0.19;
    s2 = s*0.002743;
    s3 = s*0.002995;
    cout << s << " тенге (KZT) = " << s1 << " RUB, " << s2 << " EUR, " << s3 << " USD" << "\n";<br>    return 0;
}

Пример:
1 тенге (KZT) = 0.19 RUB
1 тенге (KZT) = 0.002743 EUR
1 тенге (KZT) = 0.002995 USD
Введите сумму в тенге:20000
20000 тенге (KZT) = 3800 RUB, 54.86 EUR, 59.9 USD

2 a)
#include
using namespace std;

int main()
{
    int a = 5;
    int b = 4;
    int c;
    c = a;
    a = b;
    b = c;
    cout << "a = " << a << ", b = " << b << "\n";<br>    return 0;
}

Результат:
a = 4, b = 5

2 b)
#include
using namespace std;

int main()
{
    int a = 5;
    int b = 4;
    a = a+b;
    b = a-b;
    a = a-b;
    cout << "a = " << a << ", b = " << b << "\n";<br>    return 0;
}

Результат:
a = 4, b = 5

3)
#include
using namespace std;

int main()
{
    int a, b, c;
    a = 5;
    b = a+3;
    c = a+b;
    cout << "a = " << a << ", b = " << b << ", c = " << c << "\n";<br>    return 0;
}

Результат:
a = 5, b = 8, c = 13

4)
#include
using namespace std;

int main()
{
    int p1=10;
    int p2=15;
    int p3=12;
    int k1, k2, k3, s;
    cout << "k1 = ", cin >> k1, cout << "\n";<br>    cout << "k2 = ", cin >> k2, cout << "\n";<br>    cout << "k3 = ", cin >> k3, cout << "\n";<br>    s = p1*k1+p2*k2+p3*k3;
    cout << "Общая стоимость покупок = " << s << "\n";<br>    return 0;
}
k1 = 2
k2 = 5
k3 = 3
Общая стоимость покупок = 131

(194k баллов)