Помогите написать программу с использованием с++ вводится кол-во чисел <100, а затем сами...

0 голосов
39 просмотров

Помогите написать программу с использованием с++ вводится кол-во чисел <100, а затем сами числа:1)вывести все числа которые больше ср.ар минимального и максимального числа. 2)вывести все числакоторые меньше ср.ар всех чисел. 3)вывести все числа которые кратны 5


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

#include

int main(){
 int a[100],n,i,min,max,s;    
 scanf("%d",&n);
 if(n > 0){
  scanf("%d",&a[0]);
  min = max = s = a[0];
 }
 for(i = 1; i < n; i++){
  scanf("%d",&a[i]);
  s += a[i];
  if(a[i] < min) min = a[i];
  if(a[i] > max) max = a[i];     
 }
 printf("\n1: ");
 for(i = 0; i < n; i++)
  if(a[i]*2 > min + max)
  printf("%d ",a[i]);
 printf("\n2: ");
 for(i = 0; i < n; i++)
  if(a[i]*n < s)
  printf("%d ",a[i]);
 printf("\n3: ");
 for(i = 0; i < n; i++)
  if(a[i]%5 == 0)
  printf("%d ",a[i]);
 return 0;
}

(8.5k баллов)