Хепланите плиз Написать программу ** языке Pascal Вариант 4

0 голосов
30 просмотров

Хепланите плиз
Написать программу на языке Pascal
Вариант 4


image

Информатика (26 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var pi,inR: real;

function a(RR:real; n:integer):real;
begin
 a := 2*RR*sin(pi/n)
end;

function r(RR:real; n:integer):real;
begin
 r := RR * cos(pi/n)
end;

function S(RR:real; n:integer):real;
begin
 S := a(RR,n) * n * r(RR,n) / 2
end;

begin
 pi := 4 * arctan(1);
 read(inR);
 writeln(S(inR,10));
 writeln(S(inR,50));
 writeln(S(inR,100))
end.

(8.5k баллов)