Напишите программу, которая меняет местами первую и последнюю цифру натурального...

0 голосов
151 просмотров

Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (ABC Pascal)


Информатика (12 баллов) | 151 просмотров
Дан 1 ответ
0 голосов

Var
a,chislo,t:longint; 
c,nov,posl:integer; 
begin 
readln(a); 
posl:=a mod 10; 
chislo:=a; 
t:=1; 
repeat 
a:=a div 10; 
t:=t*10; 
until a<10; </span>
chislo:=chislo mod t; 
chislo:=posl*t+chislo-posl+a; 
writeln(chislo); 
readln; 
end.

(1.6k баллов)
0

мы не изучали (repeat, until) так что задача в моем случае решается не так... (((