Помогите пожалуйста! Нужно написать программу которая возводит число(n) в какой то...

0 голосов
30 просмотров

Помогите пожалуйста!
Нужно написать программу которая возводит число(n) в какой то системе счисления(p) в какую то другую (q). (системы счисления до 10)
Самое главное, не понимаю как перевести число в десятичную систему счисления на паскале(не всю если программу то хотя бы этот цикл по возведению числа в степень) .


Информатика (359 баллов) | 30 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Function aToDec(n:string;k:integer):longint;
{ Перевод из системы по основанию k в десятичную }
var
  i:integer;
  pa,s:longint;
begin
  s:=0;
  pa:=1;
  for i:=Length(n) downto 1 do begin
    s:=s+pa*(Ord(n[i])-Ord('0'));
    pa:=pa*k
    end;
  aToDec:=s
end;

function DecToa(n:longint;k:integer):string;
{ Перевод из десятичной системы в систему по основанию k }
var
  s:string;
  c:integer;
begin
  s:='';
  c:=Ord('0');
  while n>0 do begin
    s:=Chr(c+n mod k)+s;
    n:=n div k
    end;
  DecToa:=s
end;

function AtoB(s:string;A,B:integer):string;
{ Перевод из системы по основанию A в систему по основанию B }
begin
  AtoB:=DecToa(aToDec(s,A),B)
end;
    
var
  a,b:integer;
  n:string;
begin
  Write('Число в c/c по основанию [2;10]: '); Readln(n);
  Writeln('Укажите исходное и результирующее основания: ');
  Read(a,b);
  Writeln(n,'(',a,') = ',AtoB(n,a,b),'(',b,')');
end.

Пример решения
Число в c/c по основанию [2;10]: 643342414
Укажите исходное и результирующее основания:
7 9
643342414(7) = 80050347(9)

(150k баллов)
0

Замечание: при неверной записи числа или нарушения требований к основаниям систем счисления программа может повести себя непредсказуемо! Можно добавить проверки и диагностику, но при этом объем программы существенно возрастет и алгоритм усложнится.

0

Спасибо большое! Правда задавали нам без строк, а с функциями, массивами и тд.. Но все равно огромное спасибо!

0

Поскольку Вы не написали ничего ни о пожеланиях, ни об ограничениях, я выбрал вариант, который мне показался наиболее эффективным.