Написать программу, которая вводит n элементов массива и вычисляет сумму первого и...

0 голосов
37 просмотров

Написать программу, которая вводит n элементов массива и вычисляет сумму первого и максимального элемента массива


Информатика (16 баллов) | 37 просмотров
Дано ответов: 2
0 голосов

Случайным образом вводятся целые числа от 0 до 999.
max - максимальный элемент массива
i - цикловая переменная.

var
a : array [1..100] of integer;
max, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
max :=  a [ 1 ];
for i := 2 to n do
if a [ i ] > max then
max :=  a [ i ];
writeln (max + a [ 1 ])
end.

(2.5k баллов)
0 голосов

uses crt;

var
  a:array [1..1000] of integer;
  max,i,k:integer;
begin
  write('Введи количество элементов массива: '); read(k);
  for i:=1 to k do
  begin
    a[i]:=random(100)-50;
    write(a[i]:4);
  end;

  writeln;
  max:= a[1];
  for i:=1 to k do
    if a[i]>max then max:=a[i];
  writeln('Максимальный элемент: ',max);
  writeln ('Сумма первого и максимального элементов: ',max+a[1])
end.

(7.2k баллов)