Написать программу которая проверяет находится ли в массиве введенное с клавиатуры число....

0 голосов
188 просмотров

Написать программу которая проверяет находится ли в массиве введенное с клавиатуры число. массив должен вводиться случайным образом(pascal)


Информатика | 188 просмотров
Дано ответов: 2
0 голосов

В массиве n элементов.
Случайным образом вводятся целые числа от 0 до 999.
x - ведённое с клавиатуры число.
i - цикловая переменная.

var
a : array [1..100] of integer;
x, i, n : integer;
begin
readln (n);
for i := 1 to n do
a [ i ] := random (1000);
readln (x);
for i := 1 to n do
if a [ i ] := x then
writeln ('введённое с клавиатуры число находится в массиве');
end.

Если количество элементов в массиве известно изначально, например 25,  тогда строку " readln (n); " убираете, а строки
" for i := 1 to n do "
заменяете на
" for i := 1 to 25 do "

Минус данной программы: если введённое с клавиатуры число не находится в массиве, то программа ничего не выводит.

(2.5k баллов)
0 голосов

var

  a:array [1..100] of integer;

  i,n,k:integer;

  f:boolean;

begin

  write ('Razmer massiva (N<100): ');readln(n);</p>

  for i:=1 to n do begin

    a[i]:=random(36)-10;

    write (a[i],' ');

  end;

  writeln; 

  write ('Number: ');readln(k);

  f:=false;

  for i:=1 to n do

    if a[i]=k then f:=true; 

  writeln (f);

  readln;

end.

Выводит FALSE, если в масиве нет числа,иначе выводит TRUE.

(2.8k баллов)