Напишите программу, которая вводит натуральные числа а и b и выводит ** экран все...

0 голосов
531 просмотров

Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр.
Входные данные
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести в одну строчку все натуральные числа на отрезке [ a , b ] , делящиеся на каждую из своих цифр. Числа разделяются пробелами.
Примеры
Входные данные
10 20
Выходные данные
11 12 15
На паскале


Информатика (1.6k баллов) | 531 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    a, b, i, t:integer;
    c:boolean;
begin
    read (a, b);
    for i := a to b do
        begin
            t := i;
            c := true;
            repeat
                if (t mod 10 = 0) or (i mod (t mod 10) <> 0)
                    then c := false;
                t := t div 10;    
            until t > 0;
            if c = true then write (i, ' ')
        end;
end.

(2.1k баллов)