Помогите написать программу ** паскале "Ввести число от 0 до 24 и вывести фразу «Доброе...

0 голосов
88 просмотров

Помогите написать программу на паскале "Ввести число от 0 до 24 и вывести фразу «Доброе утро», «Добрый день», «Добрый вечер», «Спокойной ночи» в зависимости от времени суток. Пример: Введите число от 0 до 24: 12 Добрый день!"


Информатика (12 баллов) | 88 просмотров
Дан 1 ответ
0 голосов

uses crt;
var day:integer;
begin
writeln(day);
if (day > 0) and (day < 25) then
case day of

0:writeln('Good night!');;
1:writeln('Good night!');;
2:writeln('Good night!');;
3:writeln('Good night!');;
4:writeln('Good morning!');;

24:writeln('Good night!');
end.

 

дальше доделай сам

(1.6k баллов)