Чуваки, помогите. Не шарю совсем, надо написать программу и лучше с объяснениями. Дано...

0 голосов
21 просмотров

Чуваки, помогите. Не шарю совсем, надо написать программу и лучше с объяснениями.
Дано натуральное число. Верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)


Информатика (15 баллов) | 21 просмотров
0

Куда уж мне до вас! Взрослый дядька, а сидите здесь

0

Задание уже не отредактировать. Вынужден покинуть столь увлекательную беседу

0

Ох, эникейщик, язык меняется. Он же задавал вопрос школьникам, которых такое обращение не обижает.

0

Обращение автора вопроса, действительно, неуместно. Однако и "воспитательная беседа" не многим лучше.

0

Лучше, на мой взгляд, никого не оскорблять.

Дан 1 ответ
0 голосов
Правильный ответ

Требуемая программа:
var n,a: longint; b: boolean;
begin
readln(n);
readln(a);
b:=false;
while n>0 do
 begin
 if n mod 10 = a then b:=true;
 n:=n div 10;
 end;
if b 
 then writeln('В числе есть введенная цифра')
 else writeln('В числе нет введенной цифры');
end.

Пример:
1236548
2
В числе есть введенная цифра

(194k баллов)