ПОМОГИТЕ ПОЖАЛУЙСТА/ИВТ 9 КЛАСС ДЕЛФИ / ПАСКАЛЬ/ 50 БАЛЛОВ Напишите программу, которая по данному натуральному числу n выводит все его простые натуральные делители с учетом кратности. Время работы программы должно быть пропорционально корню из n. Входные данные Программа получает на вход одно число n<2^31.<br> Выходные данные Программа должна вывести все простые натуральные делители числа n с учетом кратности в порядке неубывания. Примеры входные данные 6 выходные данные 2 3
Var n,d,k:int64; begin read(n); d := 2; k := 4; while k <= n do<br> begin while n mod d = 0 do begin write(d,' '); n := n div d; end; k := k + 2*d + 1; d := d + 1; end; if n > 1 then write(n); end.
а нужно ОК
это задача 148, посмотрите пожалуйста
пять тестов не проходит по времени
ПараметрЗначениеТест Первый непройденный тестПревышено максимальное время работы55 Максимальное процессорное время1.08856 Максимальный расход памяти588185613 Максимальное астрономическое время1.35263
Пока что не знаю, как это можно исправить
Получилось, вроде
что получилось? Да, так все работает отлично, но на сайте некоторые по времени не проходят тесты. Вы можете зайти на этот сайт. informatics.mccme.ru
Нет, в смысле, вы видели, я изменил программу?
Протестировал на сайте, у меня по времени теперь все проходит
Да, все прошло. СПАСИБО ВАМ ОГРОМНОЕ!!!!