Написать программу ** Pascal,для вычисления значения функции F(x)= а) =0.5 при x-1 б)=0...

0 голосов
49 просмотров

Написать программу на Pascal,для вычисления значения функции F(x)=
а) =0.5x^2 при x\geq-1
б)=0 при x=0
в)=x+3 при x<-1<br>
x=[-3;4] с шагом 0,5


Информатика (17 баллов) | 49 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

На самом деле условие F(х)=0 при х=0 лишнее, поскольку значение F(x)=0.5x² при x≥-1 и так дает F(0)=0.

var
  x,F:real;
begin
  x:=-3;
  while x<4.01 do begin<br>    if x<-1 then F:=x+3<br>    else F:=0.5*x*x;
    Writeln('x=',x:4:1,', F=',F:5:3);
    x:=x+0.5
    end
end.

Результат
x=-3.0, F=0.000
x=-2.5, F=0.500
x=-2.0, F=1.000
x=-1.5, F=1.500
x=-1.0, F=0.500
x=-0.5, F=0.125
x= 0.0, F=0.000
x= 0.5, F=0.125
x= 1.0, F=0.500
x= 1.5, F=1.125
x= 2.0, F=2.000
x= 2.5, F=3.125
x= 3.0, F=4.500
x= 3.5, F=6.125
x= 4.0, F=8.000

(150k баллов)
0

x= 3,5+0,5=4 т.к. [-3;4]

0 голосов

Var x:real;
begin
x:=-3;
while x<=4 do begin<br> if x>=1 then writeln('F(x) = ',sqr(x)/2); 
 if x=0 then writeln('F(x) = 0');
 if x<-1 then writeln('F(x) = ',x+3);<br>x:=(x+0.5);
end
end.

(1.1k баллов)